Lifesize Support Helpdesk - Phone Issue
Incident Report for Lifesize Cloud
Resolved
Resolved - Full phone service has been restored. The phone outage which left our support number down has been remedied.
Posted 6 months ago. Oct 26, 2017 - 14:39 CDT
Update
UPDATE: We have switched our phone system onto our backup line. You are able to reach us using 512-233-6768. We apologize about the inconvenience and will update once we are fully back up.
Posted 6 months ago. Oct 26, 2017 - 13:23 CDT
Investigating
Our Support Helpdesk telephone system is currently offline. We are working with our provider on restoring the services and will continue to post updates here. As an alternative, you can contact via www.lifesize.com to chat with us live or submit a support ticket. Our apologies as we work to resolve the issue.
Posted 6 months ago. Oct 26, 2017 - 12:51 CDT