Management Console Issue
Incident Report for Lifesize Cloud
Resolved
All Management console services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 11 months ago. Jul 25, 2017 - 09:18 CDT
Investigating
Thank you for your patience while we address an issue with the web console. You may be unable to access your web console at this time.
Posted 11 months ago. Jul 25, 2017 - 08:28 CDT