Audio Conferencing Service Issue
Incident Report for Lifesize Cloud
Resolved
We’re happy to let you know that the Lifesize PSTN +81 3-4589-5640 in Japan has been successfully restored. We apologize for any inconvenience this may caused.
Posted 6 months ago. Feb 13, 2018 - 06:47 CST
Investigating
Thank you for your patience while we address an issue with our JAPAN PSTN dial in audio conferencing service. Some users may experience difficulties placing audio calls at this time.

The Lifesize PSTN no. +81 3-4589-5640 in Japan is temporarily down.
Posted 6 months ago. Feb 13, 2018 - 01:29 CST