Lifesize Support Helpdesk
Incident Report for Lifesize Cloud
Resolved
Full phone service has been restored. The phone outage which left our support number a local Austin/US number has been remedied.
Posted 23 days ago. Aug 29, 2017 - 16:54 CDT
Update
UPDATE! Due to the unfortunate events surrounding Hurricane Harvey, our telephone system is only able to connect via a US-based Austin number. That number is (512) 233-6768. We are working with our provider to restore toll free services and will keep you updated. You can also contact us using the Live Chat option in community or through the website at http://www.lifesize.com/support to submit a support ticket. Our apologies as we work to resolve the issue.
Posted 24 days ago. Aug 28, 2017 - 17:20 CDT
Update
Due to the unfortunate events surrounding Hurricane Harvey, our telephone system is only able to connect via a US-based Austin number. That number is (512) 223-6768. We are working with our provider to restore toll free services and will keep you updated. You can also contact us using the Live Chat option in community or through the website at http://www.lifesize.com/support to submit a support ticket. Our apologies as we work to resolve the issue.
Posted 24 days ago. Aug 28, 2017 - 17:14 CDT
Identified
Due to the unfortunate events with Hurricane Harvey, our Support Helpdesk telephone system is offline. We are working with our provider on restoring the services and will continue to post updates here. As an alternative, you can contact via www.lifesize.com to chat with us live or submit a support ticket. Our apologies as we work to resolve the issue.
Posted 24 days ago. Aug 28, 2017 - 05:59 CDT