Management Console Issue
Incident Report for Lifesize Cloud
Resolved
All Management console services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 3 months ago. May 24, 2017 - 08:59 CDT
Investigating
Thank you for your patience while we address an issue with the web console. You may be unable to access your web console at this time.
Posted 3 months ago. May 24, 2017 - 08:44 CDT