Audio Conferencing Service Issue
Incident Report for Lifesize Cloud
Resolved
All audio conferencing services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 3 months ago. May 23, 2017 - 15:55 CDT
Investigating
Thank you for your patience while we address an issue with our India PSTN dial in audio conferencing service. Some users may experience difficulties placing audio calls at this time.
Posted 3 months ago. May 23, 2017 - 09:26 CDT