Management Console Issue
Incident Report for Lifesize Cloud
Resolved
All Management console services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 5 months ago. Apr 24, 2018 - 12:13 CDT
Investigating
Thank you for your patience while we address an issue with the web console. You may be unable to access your web console at this time.

We are working to resolve this issue as soon as possible
Posted 5 months ago. Apr 24, 2018 - 10:48 CDT