Lifesize Cloud Amplify Recording Service Issue
Incident Report for Lifesize Cloud
Resolved
All Lifesize Streaming services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 7 months ago. Mar 22, 2018 - 11:19 CDT
Investigating
Thank you for your patience while we address an issue with our Lifesize Cloud Streaming service. Some users may be unable to stream live at the moment.
Posted 7 months ago. Mar 22, 2018 - 11:11 CDT