Audio Conferencing Service Issue
Incident Report for Lifesize Cloud
Resolved
We’re happy to let you know that the Lifesize PSTN no. +39 06 4520 0617 in Italy has been successfully restored. We apologize for any inconvenience this may caused.
Posted about 1 month ago. Nov 12, 2018 - 06:11 CST
Investigating
Thank you for your patience while we address an issue with our Italy PSTN dial in audio conferencing service. Some users may experience difficulties placing audio calls at this time.

The Lifesize PSTN no. +39 06 4520 0617 in Italy is temporarily down.
Posted about 1 month ago. Nov 12, 2018 - 05:55 CST
This incident affected: Audio Call Service.