Group Calling and Virtual Meeting Room Issue
Incident Report for Lifesize Cloud
Resolved
All Group Calling services have been successfully restored. We apologize for any inconvenience this may caused.
Posted about 1 year ago. Mar 28, 2017 - 18:49 CDT
Investigating
Thank you for your patience while we address an issue with our group calling service. Some users may see unexpected behavior when you place a group call or join a meeting. Please standby for an update.
Posted about 1 year ago. Mar 28, 2017 - 18:29 CDT