Management Console Outage
Incident Report for Lifesize Meeting Solutions Cloud
Resolved
manage.lifesize.com logins should now be working.

Sorry for any inconvenience.
Posted Jul 29, 2015 - 19:28 UTC
Investigating
The manage.lifesize.com site is currently not allowing logins.

We are investigating.
Posted Jul 29, 2015 - 19:15 UTC