Audio Conferencing Service Issue
Incident Report for Lifesize Meeting Solutions Cloud
Resolved
We’re happy to let you know that the Lifesize PSTN +49 40 401198525 in Germany has been successfully restored. We apologize for any inconvenience this may caused.
Posted Apr 11, 2018 - 13:37 UTC
Investigating
Thank you for your patience while we address an issue with our Germany PSTN dial in audio conferencing service. Some users may experience difficulties placing audio calls at this time.

The Lifesize PSTN no. +49 40 401198525 in Germany is not recognizing DTMF tones.
Posted Apr 11, 2018 - 12:51 UTC