Notification: Support Team Contact Number
Incident Report for Lifesize Meeting Solutions Cloud
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 02:17 UTC
Investigating
Lifesize Support Team contact numbers of India, EMEA and APAC are currently down. You can reach out to Support Team using US number +877-543-3749 or open case through Lifesize Community Login and Chat service. We regret the inconvenience caused, we are working with carrier to fix the issue soon.
Posted Oct 10, 2020 - 17:34 UTC
This incident affected: Audio Call Service.