Error Message with 877-LIFESIZE
Incident Report for Lifesize Cloud
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 15:09 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2020 - 13:48 CDT
Identified
Lifesize is currently investigating an error when dialing our 1-877-LIFESIZE number, please use +1 855 645 0108 in the interim to reach us. We will be posting updates as they become available. Thank you for your patience.
Posted Sep 08, 2020 - 17:24 CDT
This incident affected: Community.