Lifesize Support Helpdesk - Phone Issue
Incident Report for Lifesize Cloud
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 29, 2019 - 14:05 CDT
Investigating
We are currently experiencing issues with our Support phone number 877-347-9333 and it is temporarily unavailable. Customers can call into our alternate numbers 877-543-3749 or (512) 347-9300.
Posted 5 months ago. Feb 27, 2019 - 13:01 CST