Calls from Skype for Business to Lifesize cloud not working
Incident Report for Lifesize Cloud
Resolved
Skype for Business services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 25 days ago. Jul 25, 2019 - 06:45 CDT
Investigating
We are currently facing issues while calling from Skype for Business to Lifesize cloud. We found the issue at approximately 4:30 am Thursday, CDT Time.

Our engineering team is investigating the issue and we will update once the service is restored.

Apologies for the inconvenience caused.
Posted 25 days ago. Jul 25, 2019 - 05:23 CDT
This incident affected: Multiway Call Service.