Verification is currently underway for the maintenance items.
Posted Oct 04, 2025 - 20:59 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2025 - 20:00 UTC
Scheduled
We will update systems for client connection establishment and device upgrade detection. While doing so, we prioritize minimizing any impact on system usability. In most instances, this process is seamlessly integrated and is unnoticeable.
Posted Oct 04, 2025 - 18:06 UTC
This scheduled maintenance affected: Call Management Service, Lifesize Icon, and Web Application call service.