Audio Conferencing Service Issue
Incident Report for Lifesize Cloud
Resolved
All audio conferencing services have been successfully restored. We apologize for any inconvenience this may caused.
Posted 10 months ago. Sep 26, 2017 - 12:15 CDT
Investigating
Thank you for your patience while we address an issue with our audio conferencing service. Some users may experience difficulties placing audio calls at this time.

Local number 512-489-3100 is temporarily down but 844-572-5683 and 512-823-0450 are both still working.
Posted 10 months ago. Sep 26, 2017 - 10:55 CDT