Invite Links
Incident Report for Lifesize Cloud
Resolved
We are happy to let you know that all issues with the Invite Links have been resolved and we are back in action.
Posted 10 months ago. Feb 15, 2017 - 10:01 CST
Monitoring
We’re back! We are happy to let you know that all issues with the Invite Links have been resolved and we are continuing to monitor the service.
Posted 10 months ago. Feb 15, 2017 - 09:00 CST
Investigating
Thank you for your patience while we investigate some reported issues related to our Invite Links. Please stand by for an update.
Posted 10 months ago. Feb 15, 2017 - 08:06 CST