Call Management Issue

Incident Report for Lifesize Meeting Solutions

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 01:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2025 - 01:07 UTC

Identified

Thank you for your patience while we address an issue with our call service. Some users may be unable to place calls at the moment.
Posted Mar 12, 2025 - 00:56 UTC
This incident affected: Call Management Service.