We are awaiting final confirmation of full recovery from our cloud provider and have moved this incident to a Monitoring state. Early mitigation steps to fail over dependencies from the affected region to redundant regions significantly minimized the overall impact.
Posted Oct 20, 2025 - 20:59 UTC
Identified
We are observing early signs of recovery; however, Multiway Call services and Connect Plus Gateway calls may still experience intermittent failures. Our team is actively working and monitoring the situation to ensure full restoration.
Posted Oct 20, 2025 - 14:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:36 UTC
Monitoring
We have observed service degradation on Lifesize cloud Platform, due to an ongoing AWS incident( https://health.aws.amazon.com/health/status ) with their US1 Region. Now we confirm all our services are working fine at the moment and we are actively monitoring the platform. Once we receive confirmation from AWS services partner regarding the resolution, we will mark this incident as resolved.
Posted Oct 20, 2025 - 12:36 UTC
This incident affected: Audio Call Service, Call Management Service, Multiway Call Service, and Recording Service.