Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2023 - 09:00 CST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 07, 2023 - 12:24 CST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 07, 2023 - 11:12 CST
Scheduled
Lifesize Engineering will be performing software updates to Lifesize Icon 300/500/700 video systems subscribed to Preview Channel.
Time Window: From March 10th 9 am CST to March 12th 9 pm CST. Lifesize Icon 300/500/700 video systems paired with the Lifesize Cloud and subscribed to Preview Channel will automatically upgrade to version 4.4.0 overnight during the maintenance window.
This is a major update and will change the functionality of Lifesize Connect Plus + configuration. The following information will be updated:
Please note: • This upgrade will not impact ICONs video systems subscribed to GA channels. • After upgrading to 4.4.0, the Zoom, MS Teams, and Chrome apps will be deleted. Please refer to the Deployment Guide for more information.
Posted Mar 06, 2023 - 01:46 CST
This scheduled maintenance affected: Lifesize Icon.