Microsoft 365 Calendar Service for Icon is impacted
Incident Report for Lifesize Meeting Solutions
Resolved
Microsoft has updated the interfaces used by the calendar integration for Lifesize Icon and customers will need to consent to new permissions in order for Icon devices to start receiving events again:
https://support.lifesize.com/product/release-notes/cloud-services/#Calendar-Service
Posted Oct 03, 2024 - 16:00 UTC
Monitoring
A fix has been implemented and we are monitoring the results. Customers with Microsoft 365 calendar integration for Icon will need to grant new permissions for Lifesize access to calendars:
1. Navigate to https://manage.lifesize.com/.
2. Log in as an administrator or super user for the account if prompted.
3. In the same browser window or tab, navigate to https://calendarservice.lifesizecloud.com/relink
4. Select Microsoft Office 365 and complete the Microsoft sign-in and permissions consent process.

The permissions have changed to work with new APIs from Microsoft.
Posted Oct 03, 2024 - 02:51 UTC
Identified
Lifesize customers are currently encountering challenges with the Microsoft 365 Calendar Service for Icon. Our Engineering team has pinpointed this issue's root cause and is actively involved in resolving it.
Posted Oct 01, 2024 - 15:50 UTC
This incident affected: Lifesize Icon.