Audio calling recommendations
Incident Report for Lifesize Meeting Solutions Cloud
Resolved
This incident has been resolved.
Posted May 17, 2021 - 17:39 UTC
Monitoring
Please see an important message about audio calling recommendations at https://community.lifesize.com/s/article/IMPORTANT-NOTICE-Audio-calling-recommendations. This will be a long running incident where we share updates from our providers regarding impacts to global PSTN services.
Posted Apr 01, 2020 - 07:55 UTC
This incident affected: Audio Call Service.