Maintenance was completed on 31st Jan 2023 17:00CST
Posted Feb 10, 2023 - 14:41 CST
Scheduled
We'll be rolling out changes for data services that back the Management Console's dashboard, live meetings, past meetings aggregation statistics. The changes are expected to be fully transparent with no impact to usage.
Posted Jan 31, 2023 - 13:54 CST
This scheduled maintenance affected: Management Console.