Verification is currently underway for the maintenance items.
Posted Jul 23, 2025 - 21:08 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 23, 2025 - 21:00 UTC
Scheduled
Our engineering team will conduct routine maintenance on the Lifesize Meeting Solution Cloud service. While doing so, we prioritize minimizing any impact on the underlying infrastructure for this service. In most instances, this process is seamlessly integrated and is unnoticeable.
Posted Jul 23, 2025 - 17:56 UTC
This scheduled maintenance affected: Lifesize Icon and Web Application call service.