Verification is currently underway for the maintenance items.
Posted Jul 13, 2026 - 23:56 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 13, 2026 - 23:30 UTC
Scheduled
We'll upgrade components used for web and desktop videoconferencing applications. While doing so, we prioritize minimizing impact to application services and behavior. In most instances, this process is seamlessly integrated and is unnoticeable.
Posted Jul 13, 2026 - 22:55 UTC
This scheduled maintenance affected: Web Application call service.