Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 08, 2025 - 02:00 UTC
Scheduled
Our engineering team will be conducting routine maintenance on our device monitoring service for Lifesize Icon. While doing so, we prioritize minimizing any impact on the underlying infrastructure for this service and Icon device connecitivity. In most instances, this process is seamlessly integrated and is unnoticeable.
Posted Feb 07, 2025 - 23:31 UTC
This scheduled maintenance affected: Lifesize Icon.