Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 23, 2024 - 02:02 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 23, 2024 - 02:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 22, 2024 - 17:53 UTC
Scheduled
Lifesize Engineering will be performing software updates to Lifesize Icon 300/500/700 video systems subscribed to General Availability Channel.
Lifesize Icon 300/500/700 video systems paired with the Lifesize Cloud, and subscribed to General Availability Channel will automatically upgrade to version 4.5.3 overnight during the maintenance window.