Audio Conferencing Service Issue
Incident Report for Lifesize Cloud
Resolved
We’re happy to let you know that the Lifesize PSTN no. +27 87 550 3630 in South Africa has been successfully restored. We apologize for any inconvenience this may have caused.
Posted 3 months ago. Mar 28, 2019 - 06:43 CDT
Investigating
Thank you for your patience while we address an issue with our South Africa PSTN dial in audio conferencing service. Some users may experience difficulties placing audio calls.

The Lifesize PSTN no. +27 87 550 3630 in South Africa is temporarily down.
Posted 3 months ago. Mar 26, 2019 - 08:01 CDT
This incident affected: Audio Call Service.