Degraded PSTN Performance
Incident Report for Lifesize Meeting Solutions Cloud
Resolved
This incident is resolved
Posted Jun 09, 2022 - 23:12 UTC
Update
We continue to investigate issues with our PSTN Numbers; we can confirm that the numbers below will work:

+1 (312) 392-3152
+1 (833) 881-5208
Posted Jun 09, 2022 - 19:02 UTC
Investigating
We are currently investigating an issue with degraded PSTN performance on some of our audio conference numbers.
Posted Jun 09, 2022 - 18:43 UTC
This incident affected: Audio Call Service.