Call Management Issue
Incident Report for Lifesize Cloud
Resolved
This incident has been resolved. We apologize for any inconvenience this may caused.
Posted Nov 08, 2019 - 05:47 CST
Identified
The Lifesize cloud started experiencing call connection issues in EUROPE region. We are actively working on resolving this issue. Thanks for your patience.
Posted Nov 08, 2019 - 04:50 CST
This incident affected: Call Management Service.